Основен Pc И Mac Чувствителни ли са имейлите към регистъра?

Чувствителни ли са имейлите към регистъра?



Има много объркване дали имейл адресите са чувствителни към малки и големи букви. Някои казват, че са, докато други твърдят, че не са. И така, кой е прав? В тази статия ще разгледаме дали имейл адресите са чувствителни към малки или големи букви.

Чувствителни ли са имейлите към регистъра?

Какво прави имейл адрес?

Имейл адресът се състои от три части - локалната част (известна също като потребителско име), знакът @ и частта на домейна. Всяка част има своя собствена роля и се подчинява на свой собствен набор от правила. Ето бърз преглед.

Според стандарта локалната част на имейл адреса може да бъде с дължина до 64 знака и може да бъде съставена от ограничен набор от знаци. Те включват главни и малки букви на латинската азбука, цифри от 0 до 9, точка и специални знаци. Специалните символи включват `[имейл защитен] # $% ^ & * () _- + = [] {} ~. Той е свързан с частта на домейна със знака @.

Частта на домейна може да бъде с дължина до 255 знака. Може да съдържа букви от латинската азбука (както малки, така и главни), цифри от 0 до 9 и тире. Тирето не може да стартира или завърши частта на домейна.

Могат да се използват и международни символи, макар и повече за това по-късно.

Чувства ли се малки и големи букви?

Правилният отговор на този въпрос е едновременно да и не. Според RFC 5321 , локалната част на имейл адреса е чувствителна към малки и големи букви. Това означава, че на теория [имейл защитен] не е същото като [защитен имейл] Доставчиците на електронна поща обаче имат свободата да третират локалните части като чувствителни към малки и големи букви.

Например [имейл защитен], [имейл защитен] и [имейл защитен] са теоретично различни имейл адреси. Лесно е да се види как това може да създаде проблеми и да намали потребителското изживяване, ако пощенският сървър реши да третира локалните части като чувствителни към малки и големи букви. Поради това много доставчици третират локалната част от имейл адреса като нечувствителни към регистъра.

как да демаскирате никакъв идентификатор на повикващия

Що се отнася до частта на домейна, RFC 1035 предвижда, че винаги е без значение за малки и големи букви. Това означава, че можете да го напишете с малки букви, главни букви или произволна комбинация от двете и имейлът ви ще се окаже на същия адрес. В практическа употреба [имейл защитен], [имейл защитен] и [имейл защитен] са един и същ имейл адрес.

На практика

Докато имейл адресите са само частично чувствителни към малки и големи букви, като цяло е безопасно да се считат за нечувствителни към регистъра. Всички основни доставчици, като Gmail, Yahoo Mail, Hotmail и други, третират локалните части на имейл адресите като нечувствителни към регистъра. Като се има предвид това, трябва да проверите правилата на доставчика на електронна поща, с който искате да създадете имейл.

Обвързвайки се с предишната точка, споменатият по-горе RFC 5321 препоръчва да се създават нови имейл адреси с малки букви, само за да се избегне потенциално объркване и проблеми с доставката.

От друга страна, ако вашият приятел или колега има имейл адрес с комбинация от главни и малки букви, препоръчително е да го напишете така, както е, когато им изпращате имейл. Ако не го направите, електронната поща може да не бъде доставена. Това обаче не е проблем с основните доставчици на електронна поща като Gmail, Yahoo Mail, Hotmail и други.

Освен това Gmail също не е чувствителен към точки, намерени в локалната част на имейла, когато става въпрос за идентификация на потребителски акаунт. Това означава, че ако акаунтът [защитен от имейл] съществува, няма да можете да се регистрирате [защитен от имейл] или [защитен от имейл]

Интернационализация

Първоначално имейл адресите могат да бъдат регистрирани само с помощта на буквите от латинската азбука, цифри и ограничен набор от специални ASCII символи. както и да е IETF (Internet Engineering Task Force) впоследствие разработи правила и стандарти за включване на международни символи.

RFC6530 беше първият, който включи и регулира използването на международни символи. RFC6531 разшири правилата и стандартите. Впоследствие правилата и стандартите бяха актуализирани чрез RFC6532 и RFC6533 .

Вече можете да регистрирате имейл адрес, използвайки широк спектър от азбуки, знаци и скриптове. Някои от най-широко използваните включват латински символи с диакритика, гръцка азбука, традиционни китайски иероглифи, японски символи (хирагана, катакана и канджи), кирилица, няколко индийски писмености, както и редица други.

Включването и съвместимостта с международни имейл адреси варира от доставчик до доставчик. Дори някои от най-големите доставчици не са напълно съвместими с международни адреси. Например Google ви позволява да изпращате имейл на международен адрес, но не ви позволява да го създадете. Outlook 2016 има подобна функционалност.

Заключение

За разлика от частта с име на домейн, локалната част на имейл адрес е чувствителна към малки и големи букви. Като се има предвид това, много доставчици на електронна поща решават да игнорират чувствителността към регистъра на локалната част по практически причини и да насърчават хората да създават имейли само с малки букви.

Интересни Статии

Избор На Редактора

Как да инсталирате драйвер за принтер
Как да инсталирате драйвер за принтер
Драйверът за принтер е софтуер, който казва на вашия компютър как да използва функциите на вашия принтер. Ето как да инсталирате или преинсталирате драйвер за вашия принтер.
Числата на CUSIP и как да ги търсите
Числата на CUSIP и как да ги търсите
Научете какво е CUSIP номер, какво означават знаците в един и основите за това как да търсите CUSIP номер, като използвате няколко различни метода.
8-те най-добри приложения за новини за iPhone през 2024 г
8-те най-добри приложения за новини за iPhone през 2024 г
Искате ли да сте в крак с последните извънредни новини? Тогава имате нужда от най-добрите приложения за новини за iPhone. Този списък включва всички най-предпочитани за получаване на вашите новини точно сега.
Aero Patch 1.4
Aero Patch 1.4
Ето Aero пластир, създаден от моя приятел г-н dUSHA, който позволява пълнофункционални aero стъкло и функции за персонализация в Windows 7 Home Basic и Windows 7 Starter, като например Aero Glass и оцветяване. - Пълна поддръжка на теми, включително RSS и слайдшоу. , Shake и WinFlip 3D. - Поддръжка на теми на трети страни. Най-новата версия е 1.4, вижте
Преглед на Asus Transformer Book T100: Хибридният хибрид, който започна всичко
Преглед на Asus Transformer Book T100: Хибридният хибрид, който започна всичко
Asus Transformer Book T100 беше устройството, което доведе до евтиното зареждане на Windows, но времето - и технологията - продължиха напред. От стартирането му няколко поколения нискотарифни Windows клаудбукове и Chromebook на Google преобразиха лаптопа
Как да изтрия всички публикации в Reddit
Как да изтрия всички публикации в Reddit
https://www.youtube.com/watch?v=tbWDDJ6HAeI Ако сте дългогодишен потребител на Reddit, има вероятност да съжалявате за поне няколко публикации, които сте споделили с общността. Да се ​​избягваш за споделяне на непопулярно мнение е бизнес като
Как да смените басите на Airpods
Как да смените басите на Airpods
Едно от най-добрите неща за AirPods е, че можете да персонализирате собствения си опит. Можете да слушате музика, когато пожелаете, като имате свободни ръце за изпълнение на други задачи, но това не е всичко. Вие